当前位置:棒棒糖联盟-E易语言源码站下载中心E语言源码易源码-系统工具

易语言 恶搞其他程序

运行环境:Win9X/Win2000/WinXP/Win2003/
软件语言:简体中文
软件类型:系统工具 - E语言源码 - 易源码-系统工具
授权方式:共享版
软件大小:6.00 KB
推荐星级:
更新时间:2011-04-18 08:09:46
联系方式:暂无联系方式
官方主页:Home Page
图片预览:     【一键转帖到论坛】
插件情况:
解压密码:www.52bbt.net
相关Tags:
下载统计:载入数据...
  • 好的评价 如果您觉得此软件好,就请您
      0%(0)
  • 差的评价 如果您觉得此软件差,就请您
      100%(2)

软件简介

易语言 恶搞其他程序

     说起来这个 还是 很好玩的, 为什么说是恶搞了, 因为这个程序

 可以把 消息框写到别的程序里面 去  

        看下面的代码  是重新写 程序的 pE 头 部分

 

.版本 2

局部_原文件 = 读入文件 (程序集_文件名)
局部_PE标志地址 = 寻找字节集 (局部_原文件, 到字节集 (“PE”), )
局部_记录入口点的地址 = 局部_PE标志地址 + 40
MessageBoxA = API_GetProcAddress (API_GetModuleHandle (“user32”), “MessageBoxA”)
ExitProcess = API_GetProcAddress (API_GetModuleHandle (“kernel32”), “ExitProcess”)
局部_镜像基址 = 子程序_字节集到整数 (取字节集中间 (局部_原文件, 局部_PE标志地址 + 52, 4))
局部_原入口点 = 子程序_字节集到整数 (取字节集中间 (局部_原文件, 局部_PE标志地址 + 40, 4))
局部_零区域地址 = 800
.判断循环首 (局部_零区域地址 < 取字节集长度 (局部_原文件) - 100)
    .如果真 (取字节集中间 (局部_原文件, 局部_零区域地址, 100) = 取空白字节集 (100))
        局部_可以写入 = 真
        跳出循环 ()
    .如果真结束
    局部_零区域地址 = 局部_零区域地址 + 10
.判断循环尾 ()
.如果真 (局部_可以写入 = 假)
    信息框 (“不是合格的PE文件或不能写入代码”, 0, )
    返回 ()


 

下载地址

软件评论评论内容只代表网友观点,与本站立场无关!

   评论摘要(共 0 条,得分 0 分,平均 0 分) 查看完整评论

下载说明

* 为了达到最快的下载速度,推荐使用网际快车迅雷下载本站软件。
* 请一定升级到最新版WinRAR3.80才能正常解压本站提供的软件!
* 如果您发现下载链接错误,请点击报告错误谢谢!
* 站内提供的所有软件包含破解及注册码均是由网上搜集,若侵犯了你的版权利益,敬请来信通知我们!
关于本站 - 网站帮助 - 广告合作 - 下载声明 - 友情连接- 网站地图
Copyright © 2003-2008 52bbt.Net. All Rights Reserved .
页面执行时间:2,468.75000 毫秒
Powered by:NewAsp CMS Version 4.0.0 SP2