当前位置:棒棒糖联盟-E易语言源码站下载中心E语言模块

彗星真彩控件

运行环境:Win9X/Win2000/WinXP/Win2003/
软件语言:简体中文
软件类型:E模块 - E语言模块
授权方式:共享版
软件大小:87.0 KB
推荐星级:
更新时间:2011-01-24 08:27:55
联系方式:暂无联系方式
官方主页:Home Page
图片预览:     【一键转帖到论坛】
插件情况:
解压密码:www.52bbt.net
相关Tags:
下载统计:载入数据...
  • 好的评价 如果您觉得此软件好,就请您
      100%(2)
  • 差的评价 如果您觉得此软件差,就请您
      0%(0)

软件简介


模块名称:彗星真彩控件
作者:(彬)泪闯天涯
版本:1.2

提供真彩色控件的支持。
基于GDIPlus开发,支持图像格式:PNG、JPG、GIF、BMP、TIFF、ICO

------------------------------

.版本 2

.子程序 真彩控件_销毁图片, , 公开
.参数 图片句柄, 整数型

.子程序 真彩控件_载入内存图片, 整数型, 公开, 载入指定图片,成功返回图片句柄,失败返回0
.参数 欲被载入的图片, 字节集, , 图片数据

.子程序 真彩控件_载入图片, 整数型, 公开, 载入指定图片,成功返回图片句柄,失败返回0
.参数 欲被载入的图片, 文本型, , 图片文件名

.程序集 真彩按钮, , 公开, By:(彬)泪闯天涯

.子程序 创建, 整数型, 公开, 动态创建一个“真彩按钮”控件,创建成功返回窗口句柄,失败返回0
.参数 父窗口句柄, 整数型
.参数 左边, 整数型
.参数 顶边, 整数型
.参数 宽度, 整数型
.参数 高度, 整数型
.参数 标题, 文本型, 可空

.子程序 从句柄创建, , 公开, 从现有控件创建一个“真彩按钮”
.参数 窗口句柄, 整数型
.参数 图片句柄, 整数型, 可空, 设置按钮默认状态下的图片句柄,可通过“真彩控件_载入图片”或“真彩控件_载入内存图片”取得图片句柄

.子程序 发送消息, 整数型, 公开
.参数 wMsg, 整数型, , 消息的标识符
.参数 wParam, 整数型, , 具体取决于消息
.参数 lParam, 整数型, , 具体取决于消息;

.子程序 取窗口句柄, 整数型, 公开

.子程序 是否已创建, 逻辑型, 公开

.子程序 移动, , 公开, 英文名称:move,改变窗口或窗口组件的位置或尺寸。
.参数 左边, 整数型, 可空, 单位为像素点。如被省略则不改变左边原位置。
.参数 顶边, 整数型, 可空, 单位为像素点。如被省略则不改变顶边原位置。
.参数 宽度, 整数型, 可空, 单位为像素点。如被省略则不改变宽度原位置。
.参数 高度, 整数型, 可空, 单位为像素点。如被省略则不改变高度原位置。
.参数 禁止重绘, 逻辑型, 可空

.子程序 置提示文本, , 公开
.参数 提示文本内容, 文本型
.参数 跟随鼠标, 逻辑型, 可空

.子程序 置图片, , 公开
.参数 正常图片, 整数型, 可空
.参数 点燃图片, 整数型, 可空
.参数 按下图片, 整数型, 可空
.参数 禁止图片, 整数型, 可空

.子程序 置图片数据, , 公开
.参数 正常图片, 字节集, 可空
.参数 点燃图片, 字节集, 可空
.参数 按下图片, 字节集, 可空
.参数 禁止图片, 字节集, 可空

.子程序 置显示方式, , 公开, 指定按钮图片的显示方式。0.图片居左上,1.缩放图片,2.图片居中
.参数 显示方式, 整数型, , 0.图片居左上,1.缩放图片,2.图片居中

.子程序 重画, , 公开, 英文名称:invalidate,通知 Windows 系统本窗口或窗口组件上的显示内容需要在以后被全部重画。本命令为初级对象成员命令。

.程序集 真彩编辑框, , 公开, 暂时只支持单行文本。By:(彬)泪闯天涯

.子程序 从句柄创建, , 公开, 从现有控件创建一个“真彩按钮”
.参数 窗口句柄, 整数型

.子程序 发送消息, 整数型, 公开
.参数 wMsg, 整数型, , 消息的标识符
.参数 wParam, 整数型, , 具体取决于消息
.参数 lParam, 整数型, , 具体取决于消息;

.子程序 取窗口句柄, 整数型, 公开

.子程序 取内容, 文本型, 公开

.子程序 是否已创建, 逻辑型, 公开

.子程序 移动, , 公开, 英文名称:move,改变窗口或窗口组件的位置或尺寸。
.参数 左边, 整数型, 可空, 单位为像素点。如被省略则不改变左边原位置。
.参数 顶边, 整数型, 可空, 单位为像素点。如被省略则不改变顶边原位置。
.参数 宽度, 整数型, 可空, 单位为像素点。如被省略则不改变宽度原位置。
.参数 高度, 整数型, 可空, 单位为像素点。如被省略则不改变高度原位置。
.参数 禁止重绘, 逻辑型, 可空

.子程序 置背景图片, , 公开
.参数 图片句柄, 整数型, 可空

.子程序 置背景图片数据, , 公开
.参数 图片字节集, 字节集

.子程序 置背景颜色, , 公开
.参数 背景颜色, 整数型, , -1为透明背景,否则为RGB颜色值
.参数 背景透明度, 整数型, 可空, 0-255

.子程序 置边框颜色, , 公开
.参数 边框颜色, 整数型, , -1为透明边框,否则为RGB颜色值
.参数 边框透明度, 整数型, 可空, 0-255

.子程序 置底图方式, , 公开, 指定图片框上图片的显示方式。0.图片居左上,1.缩放图片,2.图片居中
.参数 底图方式, 整数型, , 0.图片居左上,1.缩放图片,2.图片居中

.子程序 置提示文本, , 公开
.参数 提示文本内容, 文本型
.参数 跟随鼠标, 逻辑型, 可空

.子程序 置文本颜色, , 公开
.参数 文本颜色, 整数型, , RGB颜色值

.子程序 重画, , 公开, 英文名称:invalidate,通知 Windows 系统本窗口或窗口组件上的显示内容需要在以后被全部重画。本命令为初级对象成员命令。

.程序集 真彩窗口, , 公开, By:(彬)泪闯天涯

.子程序 从句柄创建, 逻辑型, 公开
.参数 窗口句柄, 整数型

.子程序 发送消息, 整数型, 公开
.参数 wMsg, 整数型, , 消息的标识符
.参数 wParam, 整数型, , 具体取决于消息
.参数 lParam, 整数型, , 具体取决于消息;

.子程序 取窗口句柄, 整数型, 公开

.子程序 是否已创建, 逻辑型, 公开

.子程序 刷新子控件, , 公开

.子程序 移动, , 公开, 英文名称:move,改变窗口或窗口组件的位置或尺寸。
.参数 左边, 整数型, 可空, 单位为像素点。如被省略则不改变左边原位置。
.参数 顶边, 整数型, 可空, 单位为像素点。如被省略则不改变顶边原位置。
.参数 宽度, 整数型, 可空, 单位为像素点。如被省略则不改变宽度原位置。
.参数 高度, 整数型, 可空, 单位为像素点。如被省略则不改变高度原位置。
.参数 禁止重绘, 逻辑型, 可空

.子程序 置图片, 逻辑型, 公开, 设置一个PNG图片当窗口外形,支持透明通道。注意:设置之后子控件将无法显示
.参数 图片句柄, 整数型, , 可通过“真彩控件_载入图片”或“真彩控件_载入内存图片”取得图片句柄

.子程序 置图片数据, 逻辑型, 公开
.参数 图片字节集, 字节集

.程序集 真彩图片框, , 公开, By:(彬)泪闯天涯

.子程序 创建, 整数型, 公开, 动态创建一个“真彩图片框”控件,创建成功返回窗口句柄,失败返回0
.参数 父窗口句柄, 整数型
.参数 左边, 整数型
.参数 顶边, 整数型
.参数 宽度, 整数型
.参数 高度, 整数型

.子程序 从句柄创建, , 公开, 从现有控件创建一个“真彩图片框”
.参数 窗口句柄, 整数型
.参数 图片句柄, 整数型, 可空, 可通过“真彩控件_载入图片”或“真彩控件_载入内存图片”取得图片句柄

.子程序 发送消息, 整数型, 公开
.参数 wMsg, 整数型, , 消息的标识符
.参数 wParam, 整数型, , 具体取决于消息
.参数 lParam, 整数型, , 具体取决于消息;

.子程序 取窗口句柄, 整数型, 公开

.子程序 是否已创建, 逻辑型, 公开

.子程序 移动, , 公开, 英文名称:move,改变窗口或窗口组件的位置或尺寸。
.参数 左边, 整数型, 可空, 单位为像素点。如被省略则不改变左边原位置。
.参数 顶边, 整数型, 可空, 单位为像素点。如被省略则不改变顶边原位置。
.参数 宽度, 整数型, 可空, 单位为像素点。如被省略则不改变宽度原位置。
.参数 高度, 整数型, 可空, 单位为像素点。如被省略则不改变高度原位置。
.参数 禁止重绘, 逻辑型, 可空

.子程序 置提示文本, , 公开
.参数 提示文本内容, 文本型
.参数 跟随鼠标, 逻辑型, 可空

.子程序 置图片, , 公开
.参数 图片句柄, 整数型, 可空

.子程序 置图片数据, , 公开
.参数 图片字节集, 字节集

.子程序 置显示方式, , 公开, 指定图片框上图片的显示方式。0.图片居左上,1.缩放图片,2.图片居中
.参数 显示方式, 整数型, , 0.图片居左上,1.缩放图片,2.图片居中

.子程序 重画, , 公开, 英文名称:invalidate,通知 Windows 系统本窗口或窗口组件上的显示内容需要在以后被全部重画。本命令为初级对象成员命令。
 

下载地址

·上一软件:汇编模块
·下一软件:injection驱动级注入

软件评论评论内容只代表网友观点,与本站立场无关!

   评论摘要(共 0 条,得分 0 分,平均 0 分) 查看完整评论

下载说明

* 为了达到最快的下载速度,推荐使用网际快车迅雷下载本站软件。
* 请一定升级到最新版WinRAR3.80才能正常解压本站提供的软件!
* 如果您发现下载链接错误,请点击报告错误谢谢!
* 站内提供的所有软件包含破解及注册码均是由网上搜集,若侵犯了你的版权利益,敬请来信通知我们!
关于本站 - 网站帮助 - 广告合作 - 下载声明 - 友情连接- 网站地图
Copyright © 2003-2008 52bbt.Net. All Rights Reserved .
页面执行时间:4,226.56300 毫秒
Powered by:NewAsp CMS Version 4.0.0 SP2